Thanks for the review Philippe,
On Mon, 08 Jul 2024 11:28, Philippe Mathieu-Daudé <phi...@linaro.org> wrote:
+ max_size = iov_size(buffer->elem->in_sg,
buffer->elem->in_num);
for (;;) {
+ if (buffer->size >= max_size) {
+ return_rx_buffer(stream, buffer);
return_rx_buffer() could be renamed
flush_input_stream_to_buffer() for clarity.
return_rx_buffer() is vague but I think flush_input_stream_to_buffer()
is more vague 🤔. I tried to use short names as much as possible and
document the purpose in doc comments. Unfortunately the device's state
machine is complex so the code complexity is necessary :/
Manos