mk <[EMAIL PROTECTED]> writes: > http://www.python.org/dev/peps/pep-0008/ > > "Function Names > > Function names should be lowercase, with words separated by > underscores as necessary to improve readability." > > However, this PEP does not recommend any particular style for naming > regular (local) variables.
Yes, it does: "Method Names and Instance Variables" applies. Any object that isn't a class is an "instance", to be named according to that section. > Personally I like "mixedCase" Nothing in PEP 8 allows mixedCase (except for the rare degenerate case where you're constrained to closely follow an existing naming convention). It's always TitleCase or lowercase, with or without underscores. > Naming both functions and variables using "lowercase with underscore > separator between words for readability" leads to confusing function > names with variable names - and distinguishing between variables and > function names just by looking at them would be nice. Functions are first-class objects in Python, and many non-function objects are callable. So, such an arbitrary distinction wouldn't be helpful. It's more sensible to distinguish by *usage*: is it being called or not? > Recommendations? Follow PEP 8, including the avoidance of mixedCase. -- \ “I went to a general store. They wouldn't let me buy anything | `\ specifically.” —Steven Wright | _o__) | Ben Finney -- http://mail.python.org/mailman/listinfo/python-list