http://www.python.org/dev/peps/pep-0008/

"Function Names

Function names should be lowercase, with words separated by underscores as necessary to improve readability."

However, this PEP does not recommend any particular style for naming regular (local) variables.

Personally I like "mixedCase", however using both styles looks a bit weird:

def some_function_name(someVariableName, anotherVar)

Naming both functions and variables using "lowercase with underscore separator between words for readability" leads to confusing function names with variable names - and distinguishing between variables and function names just by looking at them would be nice.

Recommendations?





--
http://mail.python.org/mailman/listinfo/python-list

Reply via email to