Raymond Hettinger wrote: > I would like to get everyone's thoughts on two new dictionary methods: > > def count(self, value, qty=1): > try: > self[key] += qty > except KeyError: > self[key] = qty > > def appendlist(self, key, *values): > try: > self[key].extend(values) > except KeyError: > self[key] = list(values)
-1 form me. I'm not very glad with both of them ( not a naming issue ) because i think that the dict type should offer only methods that apply to each dict whatever it contains. count() specializes to dict values that are addable and appendlist to those that are extendable. Why not subtractable, dividable or right-shiftable? Because of majority approval? I'm mot a speed fetishist and destroying the clarity of a very fundamental data structure for speedup rather arbitrary accumulations seems to be a bad idea. I would move this stuff in a subclass. Regards Kay -- http://mail.python.org/mailman/listinfo/python-list