Serhiy Storchaka added the comment: > Also, I'm reluctant to have two copies of the code for _read_block(); it > makes the code harder to read, and increases the chance of introducing a bug > when changing the code.
Recursive inline _check_can_read() will be enough. Now this check calls 4 Python functions (_check_can_read(), readable(), _check_non_closed(), closed). Recursive inlining only readable() in _check_can_read() is achieved significant but less (about 30%) effect. ---------- _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue16034> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com