Am 11.02.25 um 17:07 schrieb Daniel Kral:
> Add subroutines for asserting the content types of storages and volumes
> to reduce code duplication, e.g. when implementing preconditions in an
> API handler before calling vdisk_alloc.
> 
> Signed-off-by: Daniel Kral <d.k...@proxmox.com>
> ---
> changes since v1:
> - moved from qemu-server to pve-storage
> - add missing $node parameter to helpers
> - adapt and fix wrong docs (copy paste error)
> - remove `alloc_volume_disk` and `check_{volume,storage}_alloc`
> 
>  src/PVE/Storage.pm | 40 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 40 insertions(+)
> 
> diff --git a/src/PVE/Storage.pm b/src/PVE/Storage.pm
> index 3b4f041..ca69cd6 100755
> --- a/src/PVE/Storage.pm
> +++ b/src/PVE/Storage.pm
> @@ -529,6 +529,46 @@ sub parse_volume_id {
>      return PVE::Storage::Plugin::parse_volume_id($volid, $noerr);
>  }
>  
> +=head3 assert_content_type_supported($cfg, $storeid, $content_type [, $node])
> +
> +Asserts whether the storage with the identifier C<$storeid>, which is 
> defined in C<$cfg>, supports
> +the content type C<$content_type>.
> +
> +If C<$node> is set, the assertion is made for the specified C<$node>, else 
> for the current node.
> +
> +If the check fails, the subroutine will C<die> with an error message for 
> either the storage being
> +unavailable or the storage not supporting the specified content type.
> +

I'd rather group the functions with their respective doc. I.e.
doc+function,doc+function instead of doc+doc,function+function.

> +=head3 assert_volume_type_supported($cfg, $volid [, $node])
> +
> +Asserts whether the volume with the identifier C<$volid>, which is on a 
> storage defined in C<$cfg>,
> +supports the volume's content type determined by L<parse_volname>.
> +
> +If C<$node> is set, the assertion is made for the specified C<$node>, else 
> for the current node.
> +
> +If the check fails, the subroutine will C<die> with an error message for 
> either the storage being
> +unavailable or the storage not supporting the volume's content type.
> +
> +=cut
> +
> +sub assert_content_type_supported : prototype($$$;$) {
> +    my ($cfg, $storeid, $content_type, $node) = @_;
> +
> +    my $scfg = storage_config($cfg, $storeid, $node);

The storage_config() function does not have a $node parameter, but a
$noerr parameter. I guess you want to use storage_check_enabled() since
the documentation talks about "storage being unavailable"?

> +
> +    die "storage '$storeid' does not support content type '$content_type'\n"
> +     if !$scfg->{content}->{$content_type};
> +}
> +
> +sub assert_volume_type_supported : prototype($$;$) {
> +    my ($cfg, $volid, $node) = @_;
> +
> +    my ($storeid) = parse_volume_id($volid);
> +    my ($vtype) = parse_volname($cfg, $volid);
> +
> +    assert_content_type_supported($cfg, $storeid, $vtype, $node);
> +}
> +
>  # test if we have read access to volid
>  sub check_volume_access {
>      my ($rpcenv, $user, $cfg, $vmid, $volid, $type) = @_;



_______________________________________________
pve-devel mailing list
pve-devel@lists.proxmox.com
https://lists.proxmox.com/cgi-bin/mailman/listinfo/pve-devel

Reply via email to