On 2017-02-07 13:13:43 -0800, Jeff Janes wrote: > On Tue, Feb 7, 2017 at 1:03 PM, Robert Haas <robertmh...@gmail.com> wrote: > > > On Sun, Feb 5, 2017 at 9:48 AM, Dilip Kumar <dilipbal...@gmail.com> wrote: > > >> I think maybe we should rename the functions to element_allocate, > > >> element_free, and element_allocator_ctx, or something like that. The > > >> current names aren't capitalized consistently with other things in > > >> this module, and putting the word "element" in there would make it > > >> more clear what the purpose of this thing is. > > > > > > Fixed as per the suggestion > > > > Eh, not really. You changed the memory context to be called > > element_allocator_ctx, rather than changing the args passed to the > > element allocator to have that name, which is what I had in mind. > > > > I did some assorted renaming and other cosmetic improvements and committed > > 0002. > > > > I'm getting compiler errors: > > In file included from execGrouping.c:47: > ../../../src/include/lib/simplehash.h:91: error: redefinition of typedef > 'simplehash_allocate' > ../../../src/include/lib/simplehash.h:91: note: previous declaration of > 'simplehash_allocate' was here > ../../../src/include/lib/simplehash.h:92: error: redefinition of typedef > 'simplehash_free' > ../../../src/include/lib/simplehash.h:92: note: previous declaration of > 'simplehash_free' was here
Oh yea, that too - you can't just redefine a typedef like that according to C89 :( -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers