Michael Paquier wrote:
> On Tue, Mar 29, 2016 at 2:45 AM, Alvaro Herrera
> <alvhe...@2ndquadrant.com> wrote:
> > If you're interesting in improving translatability of this program
> > further, I suggest that messages of this sort
> >   msgid "BKPBLOCK_HAS_DATA set, but no data included at %X/%X"
> > should have a %s instead of the flag name.
> 
> I'll think about it. Though I am afraid this would reduce the code
> readability in xlogreader.c

Oh, I didn't notice these came from xlogreader.  Hmm, but isn't it just
a change like this?

*** a/src/backend/access/transam/xlogreader.c
--- b/src/backend/access/transam/xlogreader.c
***************
*** 1043,1050 **** DecodeXLogRecord(XLogReaderState *state, XLogRecord *record, 
char **errormsg)
                        if (blk->has_data && blk->data_len == 0)
                        {
                                report_invalid_record(state,
!                                         "BKPBLOCK_HAS_DATA set, but no data 
included at %X/%X",
!                                                                         
(uint32) (state->ReadRecPtr >> 32), (uint32) state->ReadRecPtr);
                                goto err;
                        }
                        if (!blk->has_data && blk->data_len != 0)
--- 1043,1052 ----
                        if (blk->has_data && blk->data_len == 0)
                        {
                                report_invalid_record(state,
!                                                                         "%s 
set, but no data included at %X/%X",
!                                                                         
"BKPBLOCK_HAS_DATA",
!                                                                         
(uint32) (state->ReadRecPtr >> 32),
!                                                                         
(uint32) state->ReadRecPtr);
                                goto err;
                        }
                        if (!blk->has_data && blk->data_len != 0)

-- 
Álvaro Herrera                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to