On 2015-07-07 06:41:55 -0700, Gurjeet Singh wrote: > There seems to be a misplaced not operator ! in that if statement, as > well. That sucks :( The MacOS gcc binary is actually clang, and its output > is too noisy [1], which is probably why I might have missed warning if any.
Which version of clang is it? With newer ones you can individually disable nearly all of the warnings. I regularly use clang, and most of the time it compiles master without warnings. > > > pg_create_physical_replication_slot(PG_FUNCTION_ARGS) > > > { > > > Name name = PG_GETARG_NAME(0); > > > + bool activate = PG_GETARG_BOOL(1); > > > > Don't like 'activate' much as a name. How about 'immediately_reserve'? > > > > I still like 'activate, but okay. How about 'reserve_immediately' instead? Activate is just utterly wrong. A slot isn't inactive before. And 'active' already is used for slots that are currently in use (i.e. connected to). > Also, do you want this name change just in the C code, or in the pg_proc > and docs as well? All. - Andres -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers