On 2014-06-05 10:57:58 +0900, Fujii Masao wrote: > On Thu, Jun 5, 2014 at 8:24 AM, Andres Freund <and...@2ndquadrant.com> wrote: > > Hi, > > > > Due to the opened window of the pg_control/catalog version bump a chance > > has opened to fix a inconsistency I've recently been pointed > > towards: > > Namely that replication slots are named 'slot_name' in one half of the > > cases and 'slotname' in the other. That's in views, SRF columns, > > function parameters and the primary_slotname recovery.conf parameter. > > > > My personal tendency would be to make it slot_name everywhere except the > > primary_slotname recovery.conf parameter. There we already have > > precedent for shortening names. > > > > Other opinions? > > I like using "slot_name" everywhere, i.e, even in recovery.conf. > primary_slot_name seems not so long name.
It also has the advantage that we can add a couple more slot_* options later. Will do that. > BTW, what about also renaming pg_llog directory? I'm afraid that > a user can confuse pg_log with pg_llog. We have: * pg_ldecoding (Heikki) * pg_lcse or pg_lcset (Petr) * pg_logical (Andres) I like, what a surprise, my own suggestion best. The name seems more versatile because it's not restricted to decoding. Greetings, Andres Freund -- Andres Freund http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Training & Services -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers