On Tue, 18 Jun 2013 11:01:28 +0200 Andres Freund <and...@2ndquadrant.com> wrote: > > /* > > * return true if attnum is out of range according to the tupdesc > > */ > > if (attnum > tupleDesc->natts) > > return true; > > I think the comment is more meaningfull before the change since it > tells us how nonexisting columns are interpreted.
I think that the comment is bad either way. Comments should explain the code, not repeat it. The above is not far removed from... return 5; /* return the number 5 */ How about "check if attnum is out of range according to the tupdesc" instead? -- D'Arcy J.M. Cain <da...@druid.net> | Democracy is three wolves http://www.druid.net/darcy/ | and a sheep voting on +1 416 788 2246 (DoD#0082) (eNTP) | what's for dinner. IM: da...@vex.net, VOIP: sip:da...@vex.net -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers