At Thu, 15 Oct 2020 17:32:10 +0900 (JST), Kyotaro Horiguchi <[email protected]> wrote in > At Thu, 15 Oct 2020 12:56:02 +0800, "[email protected]" > <[email protected]> wrote in > > Thanks for all the suggestions. > > > > >Yeah. In its current shape, it means that only pg_waldump would be > > >able to know this information. If you make this information part of > > >xlogdesc.c, any consumer of the WAL record descriptions would be able > > >to show this information, so it would provide a consistent output for > > >any kind of tools. > > I have change the implement, move some code into xlog_desc(). > > Andres suggested that we don't need that description with per-record > basis. Do you have a reason to do that? (For clarity, I'm not > suggesting that you should reving it.)
Sorry. Maybe I deleted wrong letters in the "reving" above. ==== Andres suggested that we don't need that description with per-record basis. Do you have a reason to do that? (For clarity, I'm not suggesting that you should remove it.) ==== regards. -- Kyotaro Horiguchi NTT Open Source Software Center
