Andrew Gierth <and...@tao11.riddles.org.uk> writes: > I'd been holding off responding in the hope of other opinions, but for > what it's worth, I *really* dislike having pg_dump depend magically on > some new environment variable.
Likewise. > b) new command-line option, e.g. pg_dump --extra-float-digits=0 > This is probably the safest option, IMO. Any preferences as to the > option name? I like that too, assuming that it can be made to fit into the structure of the cross-version-upgrade tests (which would have to know to use it only with >= v12 pg_dump). --extra-float-digits seems fine as a name. regards, tom lane