Hi, On 2018-09-04 18:35:34 +0530, Amit Khandekar wrote: > Subject: [PATCH 05/14] Use tts_flags instead of previous bool members > > Pack the boolean members in TupleTableSlot into a 16 bit tts_flags. > This reduces the size of TupleTableSlot since each bool member takes > at least a byte on the platforms where bool is defined as a char. > > Ashutosh Bapat and Andres Freund
> + > +/* true = slot is empty */ > +#define TTS_ISEMPTY (1 << 1) > +#define IS_TTS_EMPTY(slot) ((slot)->tts_flags & TTS_ISEMPTY) > +#define SET_TTS_EMPTY(slot) ((slot)->tts_flags |= TTS_ISEMPTY) > +#define RESET_TTS_EMPTY(slot) ((slot)->tts_flags &= ~TTS_ISEMPTY) The flag stuff is the right way, but I'm a bit dubious about the accessor functions. I can see open-coding the accesses, using the macros, or potentially going towards using bitfields. Any comments? - Andres