On Wed, 26 Sep 2018 at 05:15, Andres Freund <and...@anarazel.de> wrote: > > Hi, > > On 2018-09-04 18:35:34 +0530, Amit Khandekar wrote: > > Subject: [PATCH 05/14] Use tts_flags instead of previous bool members > > > > Pack the boolean members in TupleTableSlot into a 16 bit tts_flags. > > This reduces the size of TupleTableSlot since each bool member takes > > at least a byte on the platforms where bool is defined as a char. > > > > Ashutosh Bapat and Andres Freund > > > + > > +/* true = slot is empty */ > > +#define TTS_ISEMPTY (1 << 1) > > +#define IS_TTS_EMPTY(slot) ((slot)->tts_flags & TTS_ISEMPTY) > > +#define SET_TTS_EMPTY(slot) ((slot)->tts_flags |= TTS_ISEMPTY) > > +#define RESET_TTS_EMPTY(slot) ((slot)->tts_flags &= ~TTS_ISEMPTY) > > The flag stuff is the right way, but I'm a bit dubious about the > accessor functions. I can see open-coding the accesses, using the > macros, or potentially going towards using bitfields. > > Any comments?
I like this abstraction using macros, since this will allow us to conveniently change the way this information is stored inside the slot. I think for this same reason we have defined macros (HeapTupleIsHotUpdated, etc) for each bit of heaptuple infomask. -- Thanks, -Amit Khandekar EnterpriseDB Corporation The Postgres Database Company