On Sat, Feb 22, 2025 at 04:17:44PM +0000, David Steele wrote:
> I think for translation purposes this is probably how it needs to be but I
> wonder if we could do something like:
> 
> errdetail("Latest checkpoint in %s is at %X/%X <...>",
>           haveBackupLabel ? "pg_control" ? "backup_label",
> 
> I'll defer to Michael on that.

I think that you have the right idea here, avoiding the duplication
of the errdetail() which feels itchy when looking at the patch.  This
should have a note for translators that this field refers to a file
name.  The point is that we don't lose any context if we do a "control
file" => pg_control update in the errdetail().

This would also make the proposed patch simpler.
--
Michael

Attachment: signature.asc
Description: PGP signature

Reply via email to