Hi, > It took me a couple of days to get back to it, but attached is what I > have finished with. This was mostly OK, except for a few things: > - \close was inconsistent with the other two commands, where no > argument was treated as the unnamed prepared statement. I think that > this should be made consistent with \parse and \bindx, requiring an > argument, where '' is the unnamed statement. > - The docs did not mention the case of the unnamed statement, so added > some notes about that. > - Some free() calls were not needed in the command executions, where > psql_scan_slash_option() returns NULL. > - Tests missing when no argument is provided for the new commands. > > One last thing I have found really confusing is that this leads to the > addition of two more status flags in pset for the close and parse > parts, with \bind and \bindx sharing the third one while deciding > which path to use depending on if the statement name is provided. > That's fragile. I think that it would be much cleaner to put all that > behind an enum, falling back to PQsendQuery() by default. I am > attaching that as 0002, for clarity, but my plan is to merge both 0001 > and 0002 together.
I reviewed and tested v6. I believe it's ready to be merged. -- Best regards, Aleksander Alekseev