On Thu, Jan 25, 2024 at 11:26 AM Bertrand Drouvot <bertranddrouvot...@gmail.com> wrote: > > On Wed, Jan 24, 2024 at 04:09:15PM +0530, shveta malik wrote: > > On Wed, Jan 24, 2024 at 2:38 PM Bertrand Drouvot > > <bertranddrouvot...@gmail.com> wrote: > > > > > > I also see Sawada-San's point and I'd vote for "sync_replication_slots". > > > Then for > > > the current feature I think "failover" and "on" should be the values to > > > turn the > > > feature on (assuming "on" would mean "all kind of supported slots"). > > > > Even if others agree and we change this GUC name to > > "sync_replication_slots", I feel we should keep the values as "on" and > > "off" currently, where "on" would mean 'sync failover slots' (docs can > > state that clearly). > > I gave more thoughts on it and I think the values should only be "failover" or > "off". > > The reason is that if we allow "on" and change the "on" behavior in future > versions (to support more than failover slots) then that would change the > behavior > for the ones that used "on". >
I again thought on this point and feel that even if we start to sync say physical slots their purpose would also be to allow failover/switchover, otherwise, there is no use of syncing the slots. So, by that theory, we can just go for naming it as sync_failover_slots or simply sync_slots with values 'off' and 'on'. Now, if these are used for switchover then there is an argument that adding 'failover' in the GUC name could be confusing but I feel 'failover' is used widely enough that it shouldn't be a problem for users to understand, otherwise, we can go with simple name like sync_slots as well. Thoughts? -- With Regards, Amit Kapila.