On Wed, Jan 24, 2024 at 11:24 AM Masahiko Sawada <sawada.m...@gmail.com> wrote: > > On Wed, Jan 24, 2024 at 2:43 PM Amit Kapila <amit.kapil...@gmail.com> wrote: > > > > > > > > +/* GUC variable */ > > > +bool enable_syncslot = false; > > > > > > Is enable_syncslot a really good name? We use "enable" prefix only for > > > planner parameters such as enable_seqscan, and it seems to me that > > > "slot" is not specific. Other candidates are: > > > > > > * synchronize_replication_slots = on|off > > > * synchronize_failover_slots = on|off > > > > > > > I would prefer the second one. Would it be better to just say > > sync_failover_slots? > > Works for me. But if we want to extend this option for non-failover > slots as well in the future, synchronize_replication_slots (or > sync_replication_slots) seems better. We can extend it by having an > enum later. For example, the values can be on, off, or failover etc. >
I see your point. Let us see if others have any suggestions on this. -- With Regards, Amit Kapila.