On 6/13/23 10:27, Amit Langote wrote:
On Tue, Jun 13, 2023 at 4:44 PM David Steele <da...@pgmasters.net> wrote:

I decided to go with the following because I think it
is easier to read:

/* We only care about tables/views and can ignore subqueries, etc. */
if (!(rte->rtekind == RTE_RELATION ||
        (rte->rtekind == RTE_SUBQUERY && rte->relkind == RELKIND_VIEW)))
      continue;

It didn't occur to me so far to mention it but this could be replaced with:

     if (rte->perminfoindex != 0)

and turn that condition into an Assert instead, like the loop over
range table in ExecCheckPermissions() does.

Hmmm, that might work, and save us a filter on rte->perminfoindex later on (to filter out table partitions). Thanks for the tip!

I considered adding Assert(relkind == RELKIND_VIEW) in all places that
have the "rte->rtekind == RTE_SUBQUERY && OidIsValid(rte->relid)"
condition, but that seemed like an overkill, so only added one in the
#ifdef USE_ASSERT_CHECKING block in ExecCheckPermissions() that
f75cec4fff877 added.

This seems like a good place for the assert.

I added a comment above this Assert.

I'd like to push this tomorrow barring objections.

+1 for the new comment.

Regards,
-David


Reply via email to