On 4/6/18, Tom Lane <t...@sss.pgh.pa.us> wrote: > BTW, I experimented with adding blank lines between the hash items in the > .dat files, and that seemed to make a nice improvement in readability, > converting masses of rather gray text into visibly distinct stanzas. > I'm not dead set on that, but try it and see what you think.
Narrow entries with natural whitespace might be okay as is. The pg_aggregate example is better with blank lines, but another thing to consider is that a comment that hugs a block is clear on which entries it's referring to (pg_amop): # btree integer_ops # default operators int2 { amopfamily => 'btree/integer_ops', amoplefttype => 'int2', amoprighttype => 'int2', amopstrategy => '1', amopopr => '<(int2,int2)', amopmethod => 'btree' }, { amopfamily => 'btree/integer_ops', amoplefttype => 'int2', amoprighttype => 'int2', amopstrategy => '2', amopopr => '<=(int2,int2)', amopmethod => 'btree' }, { amopfamily => 'btree/integer_ops', amoplefttype => 'int2', amoprighttype => 'int2', amopstrategy => '3', amopopr => '=(int2,int2)', amopmethod => 'btree' }, { amopfamily => 'btree/integer_ops', amoplefttype => 'int2', amoprighttype => 'int2', amopstrategy => '4', amopopr => '>=(int2,int2)', amopmethod => 'btree' }, { amopfamily => 'btree/integer_ops', amoplefttype => 'int2', amoprighttype => 'int2', amopstrategy => '5', amopopr => '>(int2,int2)', amopmethod => 'btree' }, # crosstype operators int24 { amopfamily => 'btree/integer_ops', amoplefttype => 'int2', ... [more blocks of integer ops ...] amopmethod => 'btree' }, # btree oid_ops With a blank line beween every entry, the comments would "float" more, and the scope is not as clear. I'm okay with whatever the community thinks, but at this point I'm inclined to leave things as they are and focus on the other points of review for the next patchset. While on the subject of viewing, I do have a badly outdated patch that would create a postgres.sql file which would load into a development schema so one could query the bootstrap data in a database without running initdb. I could update it at a future point. -John Naylor