Peter Scott <[EMAIL PROTECTED]>:
> 
>      try {
>          # fragile code
>      } catch Exception::IO with {
>          # handle IO exceptions
>      } catch Exception::Socket with {
>          # handle network exceptions
>      } otherwise {
>          # handle other exceptions
>      };

I'd like to recommend just "catch" instead of "otherwise",
because sometimes you'll do this:

        try {
                # fragile code
        }
        catch {
                # handle other exceptions
        };

And it would look silly to use "otherwise" there.

You could make it so "catch" takes a list of 0 or more exception
class names.

-- 
John Porter

Reply via email to