Tomasz Maciej Nowak <tome...@o2.pl> [2019-05-04 16:01:11]: > W dniu 04.05.2019 o 00:38, Petr Štetiar pisze: > > > > SUPPORTED_DEVICES variable is used for this, so it's probably going to work, > > but if we're willing to rename it, it might be a good idea to follow the DT > > compatible naming scheme as used in other targets. > > > > So instead of this in patch 4/8: > > > > - SUPPORTED_DEVICES = $$(DEVICE_DTS) > > + SUPPORTED_DEVICES = $$(firstword $$(DEVICE_DTS)) > > > > Tomasz should be doing following: > > > > - SUPPORTED_DEVICES = $$(DEVICE_DTS) > > + SUPPORTED_DEVICES = $(subst _,$(comma),$(1)) > > Ideally that would be the case, unfortunately there is inconsistency in the > upstream > dtses, for example (stand after my patch renaming device names):
from my POV, it seems more convenient to stick to DT compatible, as it's then going to be referenced in the other places as well, so it's probably going to mean less confusion. > linksys-wrt1200ac has compatible linksys,caiman, I could still grep for wrt1200ac with the following code and find out the proper device/image: Device/linksys_caiman $(call Device/linksys,WRT1200AC (Caiman)) SUPPORTED_DEVICES += linksys-wrt1200ac ... endef TARGET_DEVICES += linksys_caiman and if we're going to rename it, we should fix all the references in the wiki as well. > marvell-armada-385-db-ap -> marvell,a385-db-ap > marvell-armada-3720-db -> marvell,armada-3720-db > marvell-armada-8040-db -> marvell,armada8040-db seems ok to me. > marvell-macchiatobin -> marvell,armada8040-mcbin quite weird, but that's a life, still DEVICE_TITLE is going to make it clear. -- ynezz _______________________________________________ openwrt-devel mailing list openwrt-devel@lists.openwrt.org https://lists.openwrt.org/mailman/listinfo/openwrt-devel