On 13/01/14 10:48, John Crispin wrote:
> Hi,
> 
> looking at the code i wonder if this is a actual bug fix or just a
> cleanup ?!
> 
> does the code behave different before and after the patch ?

It's a bug fix (this is why we have the Introduced-by clause and I
explicitly said "fix" in the subject).

The important part is this (a bit mangled for the sake of clarity):

- append network_data "mcast_rate=$mcast_rate" "$N$T"
+ append network_data "mcast_rate=$mc_rate" "$N$T"

$mcast_rate contains the raw value (i.e. 110000), while wpa_supplicant
needs the converted value contained in $mc_rate (i.e. 11).

Actually the code already computes $mc_rate properly but...it does not
use it :)


Cheers,


-- 
Antonio Quartulli

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

Reply via email to