> I favor the second option for the same reasons as Zane described, but also > don't think we need a LaunchConfiguration resource. How about just adding a > attribute to the resources such that the engine knows is not meant to be > handled in the usual way, and instead it is really a "template" (sorry for > the overloaded term) used in a scaling group. For example: > > group: > type: OS::Heat::ScalingGroup > properties: > scaled_resource: server_for_scaling > > server_for_scaling: > use_for_scaling: true ( the name of this attribute is clearly up for > discussion ;-) ) > type: OS::Nova::Server > properties: > image: my_image > flavor: m1.large > > When the engine sees the "use_for_scaling" set to true, then it does not call > things like "handle_create". Anyway, that's the general idea. I'm sure there > are many other ways to achieve a similar effect.
I'm strongly opposed to that. It reduces the readability of the template a lot for no obvious benefit. Any time you radically change behavior by putting a flag somewhere, somethings's wrong. -- Thomas _______________________________________________ OpenStack-dev mailing list OpenStack-dev@lists.openstack.org http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev