On Wed, Nov 11, 2009 at 1:58 PM, Zach Welch <z...@superlucidity.net> wrote: > On Wed, 2009-11-11 at 08:40 +0100, Øyvind Harboe wrote: >> I've read over the branch and improving types is always a good thing, >> even if I don't have a specific opinions on whether to use >> unsigned or int for iteration variables, etc. > > There is almost always a correct choice. Most of the time, there is not > really any opinion about it. There is correct and less-than-so. I mean > really... this started with the annoyance of argc being 'int' rather > than 'unsigned'. One can never have less than zero arguments, so....
In Pascal there are such types as ranges to... "unsigned" is also "wrong", only less so... I appreciate this tightened up, even if I am not directly excited about it :-) The branch definitely looked like steps in the right direction. -- Øyvind Harboe http://www.zylin.com/zy1000.html ARM7 ARM9 ARM11 XScale Cortex JTAG debugger and flash programmer _______________________________________________ Openocd-development mailing list Openocd-development@lists.berlios.de https://lists.berlios.de/mailman/listinfo/openocd-development