On Wed, May 13, 2009 at 4:40 PM, David Brownell <davi...@pacbell.net> wrote:
> On Wednesday 13 May 2009, Magnus Lundin wrote:
>> Not always, TAP_INVALID is really TAP_DONTCARE
>
> I was wondering about that.  Someone should rename it
> so it's no longer nonsense.

The point is to do away with "don't care", "default" and global variables.

There will be a well defined state that the TAP controller moves to after a
scan. The calling code defines this.

If the calling code has a concept of "default", then the calling code
implements storage to hold the "default" value.

So *all* places where TAP_INVALID is passed in as an argument would
be replaced by a specific state as defined by the calling code.



-- 
Øyvind Harboe
Embedded software and hardware consulting services
http://consulting.zylin.com
_______________________________________________
Openocd-development mailing list
Openocd-development@lists.berlios.de
https://lists.berlios.de/mailman/listinfo/openocd-development

Reply via email to