While I like "tryXYZ", I notice that this style of method naming has no precedence in the public API of JavaFX.
This is my ranking of the names suggested so far: 1. moveFocus: short and concise, may be a bit assertive 2. requestFocusTraversal: a bit wordy, but says what it'll do 3. tryMoveFocus: good, but has no precedence in JavaFX 4. traverseFocus: grammatically not quite right On Wed, Oct 23, 2024 at 9:01 PM Andy Goryachev <andy.goryac...@oracle.com> wrote: > > I like "try" very much, does not clash with multiple requestXXX in > autocompletion. > > tryMoveFocus(TraversalDirection.UP); > > -andy