On Mon, 2025-02-10 at 16:49 +0100, Etienne Cordonnier via lists.openembedded.org wrote: > From: Etienne Cordonnier <ecordonn...@snap.com> > > Duplicating the PACKAGECONFIG variable in gdb-cross and gdb-common makes > it easy to forget updating one definition without updating the other. > However at the moment there is no need for two different definitions. > > xz is also useful for gdb-cross when minidebuginfo is enabled, so it also > needs > to be in the definition of PACKAGECONFIG in gdb-cross.inc > > Let's remove the definition from gdb-cross.inc to make maintenance easier. > This enables xz for gdb-cross as side-effect. > > Signed-off-by: Etienne Cordonnier <ecordonn...@snap.com> > --- > meta/recipes-devtools/gdb/gdb-cross.inc | 1 - > 1 file changed, 1 deletion(-)
At the very least this commit message needs to be a bit clearer as there is a change of behaviour here. To be clear, this change adds: ${@bb.utils.contains('DISTRO_FEATURES', 'minidebuginfo', 'xz', '', d)} to the default PACKAGECONFIG for gdb-cross. You can't tell that from the patch. I'd also mention that there is still a different definition for gdb- cross-canadian and if we do this, they should all probably match. Whether we should do this, I'm unsure. It might be worth just adding xz unconditionally at this point by default to be honest, it isn't a huge dependency. gdb is a debugging tool, not for a minimal system. Cheers, Richard
-=-=-=-=-=-=-=-=-=-=-=- Links: You receive all messages sent to this group. View/Reply Online (#211104): https://lists.openembedded.org/g/openembedded-core/message/211104 Mute This Topic: https://lists.openembedded.org/mt/111104210/21656 Group Owner: openembedded-core+ow...@lists.openembedded.org Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [arch...@mail-archive.com] -=-=-=-=-=-=-=-=-=-=-=-