Em Tue, Oct 02, 2007 at 11:02:53PM +0200, Oliver Hartkopp escreveu: > Arnaldo Carvalho de Melo wrote: >> Em Tue, Oct 02, 2007 at 03:10:11PM +0200, Urs Thuermann escreveu: >> >>> + >>> +#ifdef CONFIG_CAN_DEBUG_DEVICES >>> +static int debug; >>> +module_param(debug, int, S_IRUGO); >>> +#endif >>> >> >> Can debug be a boolean? Like its counterpart on DCCP: >> >> net/dccp/proto.c: >> >> module_param(dccp_debug, bool, 0444); >> > > 'debug' should remain an integer to be able to specifiy debug-levels or > bit-fields for different Debug outputs. > >> Where we also use a namespace prefix, for those of us who use ctags or >> cscope. >> > > Even if i don't have any general objections to rename this 'debug' to > 'vcan_debug', it looks like an 'overnamed' module parameter for me. Is this > a genereal naming scheme recommendation for debug module_params?
[EMAIL PROTECTED] linux-2.6.23-rc9-rt1]$ find . -name "*.c" | xargs grep 'module_param(.\+debug,' | wc -l 112 [EMAIL PROTECTED] linux-2.6.23-rc9-rt1]$ find . -name "*.c" | xargs grep 'module_param(debug,' | wc -l 233 [EMAIL PROTECTED] linux-2.6.23-rc9-rt1]$ I think that helping ctags to find the definition for the debug variable to see, for instance, if it is a bitmask or a boolean without having to chose from tons of 'debug' variables is a good thing. - Arnaldo - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html