On 03/19/2019 06:25 AM, Paolo Abeni wrote:

> +u16 __netdev_pick_tx(struct net_device *dev, struct sk_buff *skb,
> +                  struct net_device *sb_dev)
>  {
>       struct sock *sk = skb->sk;
>       int queue_index = sk_tx_queue_get(sk);
> @@ -3729,6 +3729,7 @@ static u16 __netdev_pick_tx(struct net_device *dev, 
> struct sk_buff *skb,
>  
>       return queue_index;
>  }
> +EXPORT_SYMBOL(__netdev_pick_tx);
>
I would rather rename this function, now it is going to be used from many 
drivers.

Maybe the internal core-networking should be renamed as core_netdev_pick_tx()
and the 'fallback' would be named netdev_pick_tx()

Reply via email to