On Mon, Apr 11, 2016 at 01:03:52PM -0700, Florian Fainelli wrote: > On 11/04/16 12:50, Andrew Lunn wrote: > > The phys in phys_port_mask suggests this mask is about PHYs. In fact, > > it means physical ports. Rename to user_port_mask, indicating user > > ports of the switch, which is hopefully less confusing. > > Even though the change looks fine in principle, I am more worried about > the difficulty for people to backport fixes because of the renaming > happening here. How about "enabled_ports_mask" as a name?
I'm fine with that. Anything, so long as it does not contain phys. > Did not > Guenter had a helper function at some point which tested for (1 << port > & ds->phys_port_mask)? Maybe you are thinking of: static inline bool dsa_is_port_initialized(struct dsa_switch *ds, int p) { return ds->phys_port_mask & (1 << p) && ds->ports[p]; } So how about initialized_port_mask, although it is a bit long. Andrew