There has been a long running effort to refractor DSA probing to make the switches true linux devices. Here are a small collection of patches moving in this direction. Most have been seen before.
We take a little step forward by passing the dsa device point to the driver, thus allowing it to perform resource allocations using the normal mechanisms. This device structure will later be replaced by the devices own device structure. Future patches will add a true driver probe function, so we rename the current probe function, cleaning up the namespace. phys_port_mask continually confuses me, thinking it is about PHYs. But it is actually about ports to the outside world, user ports. So rename it. Lots more patches yet to follow, this is just doing some ground work. Andrew Lunn (7): net: dsa: Pass the dsa device to the switch drivers net: dsa: Have the switch driver allocate there own private memory net: dsa: Remove allocation of driver private memory net: dsa: Keep the mii bus and address in the private structure net: dsa: Rename DSA probe function. dsa: Rename phys_port_mask to user_port_mask dsa: mv88e6xxx: Use bus in mv88e6xxx_lookup_name() drivers/net/dsa/bcm_sf2.c | 24 +++++++++++++------- drivers/net/dsa/mv88e6060.c | 47 +++++++++++++++++++++++--------------- drivers/net/dsa/mv88e6060.h | 11 +++++++++ drivers/net/dsa/mv88e6123.c | 14 +++++++----- drivers/net/dsa/mv88e6131.c | 14 +++++++----- drivers/net/dsa/mv88e6171.c | 14 +++++++----- drivers/net/dsa/mv88e6352.c | 14 +++++++----- drivers/net/dsa/mv88e6xxx.c | 55 +++++++++++++++++++++++++++++++-------------- drivers/net/dsa/mv88e6xxx.h | 17 +++++++++++--- include/net/dsa.h | 16 ++++++++----- net/dsa/dsa.c | 19 +++++++++------- 11 files changed, 166 insertions(+), 79 deletions(-) -- 2.7.0