[[ This message was both posted and mailed: see
   the "To," "Cc," and "Newsgroups" headers for details. ]]

In article <201301022000.r02k0baw020...@pause.fiz-chemie.de>, "Perl
Authors Upload Server" <upl...@pause.perl.org> wrote:


>     As opposed to other module, the main functionnalities of Test::Subs
>     are that the user does not need to pre-declare the number of test to
>     run (so all modification) in a test file are locals and the
>     declaration of the tests is done with a syntax based on anonymous
>     code block, which I believe (subjectively) are cleaner and easier to
>     read than the list of value used by other module.

The Test::* namespace has a bit of a problem in that people now expect
the modules to do Test::Builder sorts of things. If you're doing
something completely different, the trick is to set your stuff apart
somehow.

However, before you go off to do a lot of work,  I'll point out that
this sounds like what I already do with Test::More subtests:

    use Test::More;

    subtest 'some_label' => sub {
        local *STDOUT = ...
        ...
        };

    done_testing();

If you still want a separate module, that's not a problem. Since I
don't have any ideas on a better name, if you still want the original
name, that's not a problem either.

-- 
brian d foy (one of many PAUSE admins), http://pause.perl.org
PAUSE instructions:  http://pause.perl.org/pause/query?ACTION=pause_04about
Archives: http://www.xray.mpe.mpg.de/mailing-lists/modules
Please send all messages back to modules@perl.org with no CC to me.

Reply via email to