This shouldn't be a functional change since reg_belongs_to_class is just a wrapper around BITSET_TEST. It just makes the code a little easier to read.
Signed-off-by: Jason Ekstrand <jason.ekstr...@intel.com> --- src/util/register_allocate.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/util/register_allocate.c b/src/util/register_allocate.c index afab9dd..6cf7ce7 100644 --- a/src/util/register_allocate.c +++ b/src/util/register_allocate.c @@ -335,7 +335,7 @@ ra_set_finalize(struct ra_regs *regs, unsigned int **q_values) for (i = 0; i < regs->regs[rc].num_conflicts; i++) { unsigned int rb = regs->regs[rc].conflict_list[i]; - if (BITSET_TEST(regs->classes[b]->regs, rb)) + if (reg_belongs_to_class(rb, regs->classes[b])) conflicts++; } max_conflicts = MAX2(max_conflicts, conflicts); -- 2.1.0 _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev