On Mon, 21 Nov 2011 15:53:09 -0800, Chad Versace <chad.vers...@linux.intel.com> 
wrote:
> From: Kenneth Graunke <kenn...@whitecape.org>
> 
> I implemented functions for horizontal/vertical alignment units separately
> because I find it easier to read that way...especially with all the
> corner-cases.
> 
> [chad] Corrected the vertical alignment calculation by checking for
> depthstencil formats.
> 
> v2:
>    - Fix typos in intel_horizaontal_texture_alingment_unit():

v3: fix typos in "horizontal" and "alignment".  (j/k)

>      s/height/width/ and s/VALIGN/HALIGN.
>    - Remove special case for compressed formats in
>      intel_get_texture_alignment unit(). Compressed formats are already
>      handled in the halign and valign functions.
>    - Replace check ``_mesa_is_depth_format(...) ||
>      _mesa_is_depthstencil_format(...)`` with explcitit checks against
>      GL_DEPTH_COMPONENT and GL_DEPTH_STENCIL.

Reviewed-by: Eric Anholt <e...@anholt.net>

Attachment: pgpYGAWAHb2QR.pgp
Description: PGP signature

_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to