>>>>> "Abdelrazak" == Abdelrazak Younes <[EMAIL PROTECTED]> writes:

Abdelrazak> Hello, This simple optimization bring (subjectively) 1
Abdelrazak> second in the scroll test. I think it is a safe and non
Abdelrazak> controversial improvement so I will commit now.

It looks safe indeed. You should also (for readability and speed)
constify variables

-       CoordCache::InnerParPosCache parPos = theCoords.parPos()[text];
+       CoordCache::InnerParPosCache const & const parPos = 
theCoords.parPos()[text];

-       Paragraph & par = text->getPar(pit);
+       Paragraph const & const par = text->getPar(pit);

(OK, I may have added too many consts, but they do help the compiler
to generate better code, and it makes the intent of the code clearer)

JMarc

Reply via email to