Abdelrazak Younes <[EMAIL PROTECTED]> writes: | * frontends/Timeout: | - emit() renamed to emitSignal() to avoid compiler confusion with Qt | emit() function (change propagated to all frontend).
This I do not like. Qt deserves a lot of flak for pushing such common names into the global namespace. The qt side of things should fix this, not other code. #ifdef emit #define qt_emit emit #undef emit #endif And then use qt_emit in all qt code. As for the patch... you are changing too much at the same time, at least I feel overwhelmed, and unable to review the patch properly. It must be possible to split this patch into more manageable pieces. | Index: src/BufferView.h | =================================================================== | --- src/BufferView.h (revision 14265) | +++ src/BufferView.h (working copy) | @@ -243,7 +232,18 @@ | bool const repaintAll() const; | /// | void const repaintAll(bool r) const; | + /// | + ViewMetricsInfo const & viewMetricsInfo(); | | + /// needs_redraw_ accessor | + /** | + This accessor is there for the WorkArea class use. The WorkArea | + must set needsRedraw to false once screen redrawing is done! | + \retval true is a redraw is needed | + \retval fasle otherwise | + */ | + bool & needsRedraw(); A binary value shoudl have a getter and a setter IMHO, not direct access to the underlying variable. -- Lgb