Andre Poenitz wrote:
On Mon, Jun 19, 2006 at 06:17:58PM +0200, Abdelrazak Younes wrote:
- Long variables are named like thisLongVariableName.
So without the trailing underscore then?
For me variables are temporary variables inside a function or variable
passed to a function. We are talking here about class members. Note that
this "thisLongVariableName" notation is used almost exclusively for
class methods and general functions. If we use that for members and
variables this would be misleading.
Really if you look at current source code it is mostly this style:
class ThisIsOneClass
{
void thisIsOneMethod(OneType one_type);
OneType one_type_;
}
I think this coding style is nice as it is not misleading. So either we
update the code rules or we change the source code. I obviously prefer
the later.
Me too.
Man, we should definitely take a decision on that! Please don't let this
discussion dye.
And to not try to force Lars making changes. We'd end up with ideas like
'do not use virtual functions in the public interface of classes' and a
free demonstration that it hurts nicely (aka 'doDispatch')
Can we forget about this for now so that I can merge my tree?
Please do.
I will now.
Thanks,
Abdel.