Abdelrazak Younes <[EMAIL PROTECTED]> writes: > > Let me start you off: > > > > class GUI { > > This is my BaseFrontend class, do you prefer BaseGui instead?
Having slept on it, I think I prefer "GUI" rather than "Frontend". We used to have BasePainter and Painter and people ended up disliking it intensely. (This was in the days when core and frontend were intertwined; people ended up using "Painter" when they should have used "BasePainter".) So, on reflection, I think that the files in src/frontends should be "Base-less". Now don't tell me that's a pain. It's 5 minutes to write the script ;-) > I think this should be merged with the Clipboard class as Qt4 does LOL! What an ugly interface! And you go from compile time checks to run time ones. So, no, I think you should have two classes. (Your Qt implementation could use a shared_ptr<QClipboard> if you want them to use the same QClipboard?) Anyway, moving on... > > * (Should the GUICursor be owned by the WorkArea then?) > > No, only connected to it by the owner when the kernel commands a > switching to this WorkArea. Hmmm. Each WorkArea "has-a" GUICursor seems like a natural fit. The frontend can tell the workArea that it is now "active" and the WorkArea will change the cursor appearance. I guess that there's the corresponding issue of telling the old work area it's now "inactive"... Things to mull over ;-) > I would call that View for the implementation and BaseView for the > virtual interface. and I would call the virtual interface lyx::frontend::Window and the implementation lyx::frontend::qt::Window ;-) > Thanks for the help, No worries. I'm doing some boring stuff here and you provide me with light relief ;-) Angus