Martin Vermeer <[EMAIL PROTECTED]> writes: This patch looks pretty good to me.
Let's get some testing done before we commit though... | Index: paragraph.C | =================================================================== | RCS file: /usr/local/lyx/cvsroot/lyx-devel/src/paragraph.C,v | retrieving revision 1.417 | diff -u -p -r1.417 paragraph.C | --- paragraph.C 25 Nov 2005 14:40:34 -0000 1.417 | +++ paragraph.C 16 Dec 2005 18:11:47 -0000 | @@ -81,7 +81,7 @@ Paragraph::Paragraph() | Paragraph::Paragraph(Paragraph const & par) | : itemdepth(par.itemdepth), insetlist(par.insetlist), | dim_(par.dim_), | - rows_(par.rows_), layout_(par.layout_), | + rows_(par.rows_), row_sig_(par.row_sig_), layout_(par.layout_), | text_(par.text_), begin_of_body_(par.begin_of_body_), | pimpl_(new Paragraph::Pimpl(*par.pimpl_, this)) | { | @@ -107,6 +107,7 @@ Paragraph & Paragraph::operator=(Paragra | | rows_ = par.rows_; | dim_ = par.dim_; | + row_sig_ = par.row_sig_; | layout_ = par.layout(); | text_ = par.text_; | begin_of_body_ = par.begin_of_body_; | Index: paragraph.h | =================================================================== | RCS file: /usr/local/lyx/cvsroot/lyx-devel/src/paragraph.h,v | retrieving revision 1.157 | diff -u -p -r1.157 paragraph.h | --- paragraph.h 7 Sep 2005 10:36:59 -0000 1.157 | +++ paragraph.h 16 Dec 2005 18:11:47 -0000 | @@ -391,7 +391,9 @@ public: | RowList & rows() { return rows_; } | /// The painter and others use this | RowList const & rows() const { return rows_; } | - | + /// | + std::vector<lyx::size_type> & row_sig() const { return row_sig_; } | + | /// LyXText::redoParagraph updates this | Dimension & dim() { return dim_; } | | @@ -408,6 +410,9 @@ private: | | /// | mutable RowList rows_; | + /// | + mutable std::vector<lyx::size_type> row_sig_; | + I do not really like the name. (sig? signal? sigarette(sp)? what?) And we should decide on what naming scheme to use. We have traditionally used the rowSignature_ style. But we have gotten a bit muddled because of the std::lib and boost interation that uses the row_signature style. I still prefere the rowSignature_ style though. Perhaps also add a typedef: typedef std::vector<lyx::size_type> RowSignature; mutable RowSignature rowSignature_; .... but what are the indices in this vector... there seems to be an implicit connection here that is not obvious? Why, did you say, is the rowSignature not placed in Row? (lyxrow) It seems to me that this should be fairly simple to do? (and would lessen the work of getting the rowList moved out of the paragraph). -- Lgb