On Sat, Dec 17, 2005 at 03:50:17PM +0100, Lars Gullik Bjønnes wrote:
> Martin Vermeer <[EMAIL PROTECTED]> writes:
> 
> This patch looks pretty good to me.
> 
> Let's get some testing done before we commit though...
 
Hear, hear.

 
> | @@ -391,7 +391,9 @@ public:
> |     RowList & rows() { return rows_; }
> |     /// The painter and others use this
> |     RowList const & rows() const { return rows_; }
> | -
> | +   ///
> | +   std::vector<lyx::size_type> & row_sig() const { return row_sig_; }
> | +   
> |     /// LyXText::redoParagraph updates this
> |     Dimension & dim() { return dim_; }
> |  
> | @@ -408,6 +410,9 @@ private:
> |  
> |     ///
> |     mutable RowList rows_;
> | +   ///
> | +   mutable std::vector<lyx::size_type> row_sig_;
> | +
> 
> I do not really like the name. (sig? signal? sigarette(sp)? what?) And
> we should decide on what naming scheme to use.
> 
> We have traditionally used the rowSignature_ style. But we have gotten a
> bit muddled because of the std::lib and boost interation that uses the
> row_signature style.
> 
> I still prefere the rowSignature_ style though.

Shall I change it to that?
 
> Perhaps also add a typedef:
> 
> typedef std::vector<lyx::size_type> RowSignature;
> mutable RowSignature rowSignature_;

OK

> .... but what are the indices in this vector... there seems to be an
> implicit connection here that is not obvious?

Yes... the row iterator counts in parallel with rowno. Not elegant but
works. Of course it wouldn't be impossible to use an iterator here
too... perhaps I'll try that.

> Why, did you say, is the rowSignature not placed in Row? (lyxrow)

The problem was that every redoParagraph refreshes the rowlist, and thus
would zero the signature. 

> It seems to me that this should be fairly simple to do?

Jean-Marc had an idea around that, but I am afraid that at this point it
would mean re-architecting too much. I started trying this but gave up. 

> (and would lessen the work of getting the rowList moved out of the
> paragraph).

Was that the plan? Sounds a bit ambitious for 1.4.0 :-)

- Martin 

Attachment: pgpfgDZjuvorN.pgp
Description: PGP signature

Reply via email to