Lars Gullik Bjønnes wrote: > This patch introduces the DispatchResult::dispatched() function and > removes DISPATCHED, UNDISPATCHED from dispatch_result_t, and changes > DISPATCHED_NOUPDATE to NOUPDATE in dispatch_reuslt_t,
The comment in dispatchresult.h still refers to DISPATCHED_NOUPDATE. Do you still need the default constructor for DispatchResult? This is a bit ugly, don't you think? cursor.dispatch(FuncRequest(func, view())).dispatched() As dispatched() now returns a bool, why not rename it as success()? The code above is then very elegant. Ditto, here result = inset->dispatch(FuncRequest(view(), action, argument)); if (result.dispatched()) { If you were to change 'result' to 'dispatch', the code would read if (dispatch.success()) { (Don't get me wrong; I think your code is a change for the good. I'm just commenting on it since you posted it.) Staying on the subject of names: if (result.val() == FINISHED) { why not rename val() as status()? if (dispatch.status() == FINISHED) { -- Angus