John Levon <[EMAIL PROTECTED]> writes:

| On Sat, Aug 10, 2002 at 08:00:08PM +0200, Lars Gullik Bjønnes wrote:
| 
| > Please review this and comment.
| 
| I don't like this "de/increasePosAfterPos" thing, it's thoroughly
| confusing to name two different things pos.
| 
| How about :
| 
|       void fixupPos(InsetList::iterator b, InsetList::iterator e, int amount)
| 
| then :
|       fixupPos(pos, end, 1)
| 
|       fixupPos(pos, end, -1)
| 
| or even
| 
|       std::for_each(pos, end, fixupPos(-1));
| 
| it's not very nice that the inset table is loosely coupled with the
| paragraph in this respect but I don't think of a better solution right
| now.

I think I agree with your comments.

But... I will apply it as is and put your comments in the InsetList.h
file.

I really have to sync up my test tree...

-- 
        Lgb

Reply via email to