Against current CVS (modulo removed file clashes I still haven't fixed) :
http://movementarian.org/q8.diff.bz2 19,000 lines of diff ... yipes I've written a short summary below of what the patch has done so far. I'm not sure what I should merge next - there are still some "move this" things to be done, but they get more tricky ... 1. Move Painter/PainterBase into frontends, and make various changes to allow GUII [PART MERGED] 2. s/LyXScreen/LScreen/ There was some grumbling about this, I'm happy to change it back if really wanted. Also move it into frontends, and make some changes to allow GUII (now a base class). xscreen implemented in xforms, plus qscreen. BV now takes a reference for screen, we do not re-create the object at any time 3. Add a screen factory for GUII virtual constructor idiom. Do same for WorkArea 4. WorkArea become a base class and has been GUIIzed to some degree. Fairly major re-workings 5. bv re-working to push weirdo scrollbar logic into xforms frontend. GUII interface is now simple and clean(ish). Also remove a few seemingly junk methods in bv + elsewhere 6. ColorHandler moved to xforms. A couple of warts (graphics/) that still rely on this, to be fixed later 7. FontInfo moved as its xforms only 8. FontLoader become xfont_loader as Qt has its own loader thankyouverymuch 9. add font_loader/xfont_loader /qfont_loader hierarchy instead 10. LyXView moved into frontends/. It only really contains frontends logic, which is why I moved it, and it forms the base class for existing (modified XFormsView) and QtView. 11. font.[Ch] now font_metrics.h / xfont_metrics.h / qfont_metrics.h. Better name, in a namespace, etc. 12. kbmap has been altered to store strings not X symbol numbers. Has to happen. 13. lyxlookup moved to xforms - obvious reasons 14. some minor GUIRunTime changes. 15. event_states.h for handling button presses etc. - GUII virtualisation 16. lkey.h - same for keypresses, now passed as strings. 17. new Qt implementations of various of these things regards john -- "This is playing, not work, therefore it's not a waste of time." - Zath