On Tuesday 26 February 2002 3:53 pm, John Levon wrote: > On Mon, Feb 25, 2002 at 07:04:37PM +0000, Angus Leeming wrote: > > > * Lazy loading. Don't try and load the file till you try to draw it. > > Your patch has a weird extra ')' that breaks the script. line 175 of GraphicsConverter.C > needs to be : > > 175 test << "if [ ! -f " << file << " ]; then\n" > > I don't see how it ever worked !
Me neither. But it did! I have fixed the horror in my tree also. > Also, the old bug where the update of the graphics inset doesn't resize > the containing inset is back. I fixed this previously, I forget how. > > I suspect a recent bugfix caused this regression. This is now a limitation of BufferView::updateInset which the GCacheItem calls explicitly in setStatus. Jürgen has said he'll have a look once this thing is in cvs. Incidentally, if you run -dbg graphics the script file is printed out to screen. Would it be a good thing for human readability if I modified this script to #!/bin/sh infile='/usr/users/aleem/OTHERS_CODE/lyx/devel/pnlg.eps' outfile='/tmp/lyx_tmpdir22451aavDta/gconvert022451aavDta.xpm' tempfile='/tmp/lyx_tmpdir22451aavDta/gconvert022451aavDta.ppm' convert ${infile} PPM:${tempfile} if [ $? -ne 0 ]; then rm' -f ${tempfile} exit 1 fi etc, rather than having the file names cluttering everything up? What say you? I have modified the code in class GImageXPM to wrap the c-style struct XpmImage up inside a c++-style class as Lars desired. The resultant code is pretty clean and works for me. Would you like to test this too, or are you happy that things are now working well enough to submit to cvs? Many thanks for doing this testing by the way. Angus