Angus Leeming <[EMAIL PROTECTED]> writes:
| Very simple one:
|
| Can I propose changing the protected status of "command", "options", "contents"
| in insetcommand.h to private? Can I also propose changing the name of "command"
| to "cmdname"? Things as they stand are a little counter intuitive.
Agree.
|
| Angus
|
|
| insetcommand.h contains:
| public:
| string const & getOptions() const { return options; }
| void setOptions(string const & o) { options = o; }
| protected:
| string options;
public:
string const & options() const { return options; }
void options(string const & o) { options = o; }
private:
string options_;
|
| public:
| string const & getContents() const { return contents; }
| virtual void setContents(string const & c) { contents = c; }
| protected:
| string contents;
public:
string const & contents() const { return contents; }
void contents(string const & c) { contents = c; }
private:
string contents_;
|
| public:
| string getCommand() const;
| string const & getCmdName() const { return command; }
| void setCmdName(string const & n) { command = n; }
| protected:
| string command;
public:
string const & cmdName() const { return cmdname; }
void cmdName(string const & c) { cmdname = c; }
private:
string cmdname_;
Would be preferred by me...
but I'd really like the public methods above to be private/protected
as well.
|
| getCommand() does not return command, but returns a concatenation of command,
| options and contents. I think that this is counter-intuitive.
mmm, agree.
Lgb