Very simple one:
Can I propose changing the protected status of "command", "options", "contents"
in insetcommand.h to private? Can I also propose changing the name of "command"
to "cmdname"? Things as they stand are a little counter intuitive.
Angus
insetcommand.h contains:
public:
string const & getOptions() const { return options; }
void setOptions(string const & o) { options = o; }
protected:
string options;
public:
string const & getContents() const { return contents; }
virtual void setContents(string const & c) { contents = c; }
protected:
string contents;
public:
string getCommand() const;
string const & getCmdName() const { return command; }
void setCmdName(string const & n) { command = n; }
protected:
string command;
getCommand() does not return command, but returns a concatenation of command,
options and contents. I think that this is counter-intuitive.