Abdelrazak Younes <[EMAIL PROTECTED]> writes:

| Comments?

I thought avalialbe a quite nice logical name to use, so I am not sure
that the code gets any cleaner by doing this.

But I won't stay in the way.
 
| Abdel.
| Index: src/BufferView.C
| ===================================================================
| --- src/BufferView.C  (revision 15017)
| +++ src/BufferView.C  (working copy)
| @@ -517,12 +517,6 @@
|  }
|  
|  
| -bool BufferView::available() const
| -{
| -     return buffer_;
| -}

BufferView::available relies on implicit cast to bool. This ok for such an easy 
function.

But that does not mean that we should rely on the same implict cast in
all places where available() is just replaced with buffer_.

| Index: src/frontends/controllers/Kernel.C
| ===================================================================
| --- src/frontends/controllers/Kernel.C        (revision 15012)
| +++ src/frontends/controllers/Kernel.C        (working copy)
| @@ -51,7 +51,7 @@
|  {
|       if (!lyxview_.view())
|               return false;
| -     return lyxview_.view()->available();
| +     return lyxview_.view()->buffer();

This one in particular I guess.

-- 
        Lgb

Reply via email to