ldionne added a comment.

Are generator expressions expanded in `if()`? If so, we could at least change 
those to `if ("$<UPPER_CASE:CMAKE_BUILD_TYPE>" STREQUAL "DEBUG")`. This would 
preserve the case-insensitivity while solving the problem you were concerned 
about, and make the code easier to read.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D89813/new/

https://reviews.llvm.org/D89813

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to